SAP Knowledge Base Article - Public

2725486 - Unable to see the field value when creating rules on CSB - Recruiting Marketing

Symptom

Users cannot see the field value they want to use when they try to create rules on CSB.

Environment

Successfactors Recruiting Marketing

Reproducing the Issue

  1. Go to CSB from Admin Center.
  2. Click on Pages. 
  3. Click on Category. 
  4. Click Edit Category page on the Category Page you wish to edit or set up the rule. 
  5. Click on Rule Editor. 
  6. Click on Edit Simple Rule Button (Pencil Icon). 
  7. Click on Select a picklist term (+ Icon) to add the field you want to use to create the rule. 
  8. The field selected does not show any value. 

Cause

The selected field is mapped to a different field RCM or there is no job which is externally posted on RMK that has that particular field value.

Resolution

  1. Make sure that there is a job posted that has the selected field value. 
  2. Make sure that the Job field mapping between RCM and RMK is properly configured. You can refer to the KBA 2557601 - Recruiting Integration - RCM-RMK Fields for Job Data Mapping - Recruiting Marketing as a guide to review the mapping. 

See Also

2302876 - Top Reasons why a job is not appearing on jobs page - Recruiting Marketing

Keywords

CSB, RMK, Category Page, Rules , KBA , LOD-SF-RMK-CSB , Career Site Builder , Problem

Product

SAP SuccessFactors Recruiting all versions