SAP Knowledge Base Article - Public

2725505 - Cannot Post Recurring Supplier Invoice. Error: "Item: HSN Code not selected"

Symptom

You cannot post a supplier invoice due to the error: "Item: HSN Code not selected". If you enter a direct description in the invoice and select a G/L Account the system shows a error for HSN code not selected but there is no option to select HSN code in recurring invoice.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Supplier Invoicing work center.
  2. Go to the Recurring Invoices view.
  3. Choose New and New Recurring Invoice.
  4. Fill in all mandatory data and choose Check or Post.
  5. You get the error: "Item: HSN Code not selected".
  6. You cannot edit the HSN Code for the item.

Cause

This is an expected system behaviour. The HSN field has not been made available for free text items in recurring invoices. Developers will check the feasibility of providing the same in future releases. However, we cannot at this point provide any release date.

Resolution

As a workaround you can create a product for the free text item and add the HSN code in the product. Using the product with HSN code will not produce the stated error.

See Also

Information: 
A HSN code should be maintained at the master data level. Click the material with double-click and the system will take you to the material in the master data.
If the item is a service, the above is applicable and you can use the workaround suggested above.

Keywords

Recurring, Supplier Invoice, HSN Code, Free Text Item, , KBA , AP-SIP-ERS , Evaluated Receipt Settlement , AP-SIP-SIV , Supplier Invoice , Problem

Product

SAP Business ByDesign 1811