Symptom
After automatic payment run, the value date used for bank accounts and bank sub-accounts in the generated payment is not as expected.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- In configuration "Set Up Bank Determination for Payment Transactions" (ID: 101045), set 'Days to value date' greater than zero under "Value date" section.
- Execute payment run via app "Manage Automatic Payments".
- Review the generated payment journal entry via app "Manage Journal Entries".
- Value Date for bank line item is incorrect.
Cause
In configuration "Set Up Bank Determination for Payment Transactions" (ID: 101045), 'Amount Limit' is set as 0,00.
Amount limit is defined as "Maximum payment amount in local currency up until which the following specifications are valid."
Resolution
In configuration "Set Up Bank Determination for Payment Transactions" (ID: 101045), add a new line with same details and specify a larger value than the payment amount in the 'Amount Limit' field under "Value date" section.
Then execute a new payment run in "Manage automatic payments" and check the value date for the generated payment journal entry.
Please note if there are multiple entries whose only difference is the amount limit in the configuration, the highest amount limit applies. The other amount limits are ignored by the system.
Keywords
Value Date, 101045, Amount Limit, Set Up Bank Determination for Payment Transactions, Days to Value Date, Bank, Manage Automatic Payments, VALUT, Cloud , KBA , FI-FIO-AP-2CL , Fiori UI for Accounts Payable (Public Cloud) , FI-AP-AP-B-2CL , Payment Progam / Payment transfer (DE, JP, US) (Public Cld) , Problem