SAP Knowledge Base Article - Public

2727052 - The Workflow E-mail is Not Triggered

Symptom

You have created a Workflow Rule to sent an email on Sales Order creation, but no email is sent even though the conditions are fullfilled.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Sales Order view (This issue is not BO specific, but using Sales Orders as an example).
  3. Select the New button.
  4. Fill in all required fields so the Workflow conditions are fullfilled.
  5. Select the Save button.
  6. An E-mail should have been send the Employee maintained in the Rule, but no E-mail was triggered.

You have checked in Fine Tuning activity E-mail and Fax Settings and you have correctly maintained the Employees E-mail domain and the button 'Send all e-mails to business partners' is selected.

Cause

A possible cause is that you have maintained an incorrect binding in the Placeholders section within the Workflow Rule. For example the placeholder #Survey114# is binded to field Changed on.

Resolution

Changed on cannot be used as a binding field. Please remove this entry and replace it with another field such as ID or External ID.

Keywords

KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions