Symptom
When trying to create a Mentor Mentee relationship, you cannot find a Mentor/ Mentee to assign/ match:
**Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental**
Environment
- SAP SuccessFactors Succession Management
- SAP SuccessFactors Mentoring
Reproducing the Issue
When trying to match a Mentee to a Mentor in the 'Matching' section (Mentoring - Admin Center) you cannot find the Mentee/ Mentor to assign.
Cause
This may be due to the Mentee/ Mentor limit being changed after the sign up phase.
For example:
- When setting up a program, you may have set the limit to 'one' for each:
2. Then a Mentor and a Mentee signed up and were matched.
3. Later the limit was increased to more than 'one'. Say for example, a Mentee limit of 6 and Mentor limit of 2.
4. Now the Mentor cannot assign another mentee because the system keeps the record of the original limit that was set
Even ending the relationship via the Mentoring Program (in Development), will not free up the slot:
Resolution
In order to free up the slot, you have to:
- Open the Mentoring program from the Admin Center
- Go to the Matches Page
- Here you have to select the Mentor to see the assigned Mentee, and click on the bin icon to manually delete:
Once Mentee is manually deleted, the Mentor can again assign a new Mentee. But note: the original limit (of one) will still be in effect.
- Note 1: When a Mentor signs up, they can also select the max Mentee limit they want to have. So if they select 'one' Mentee here, then the threshold is set to one for the duration of that program.
- Note 2: It is not possible for a Mentor to also be a Mentee. The system does not allow users to sign up as both:
Once a program has been launched, it is not possible to add further mentors or mentees.
Keywords
Mentoring, Mentor/ Mentee limit, Matching , KBA , LOD-SF-MEN-ADM , Admin Center and Setttings , LOD-SF-CDP , Career Development Planning , How To