SAP Knowledge Base Article - Public

2727116 - SAP Jam integration not working with C4C or SAP Marketing

Symptom

SAP Jam integration not working

Environment

SAP Jam

Cloud for Customer

SAP Marketing

Reproducing the Issue

Errors:

  • In the context of Data Services an unknown internal server error occurred
  • Error during processing of OData request
  • External user ID does not exist for user ____
  • Connectivity error occurred
  • HTTP client: POST failed with return code 407 and message SSL handshake with _____:443 failed

Cause

  • TLS 1.0 was disabled on all SAP Jam data centers from October 13th to November  11th, 2018 as part of a wider SAP SuccessFactors security hardening project.
  • Any systems trying to call SAP Jam now need to support using TLS 1.1 or 1.2, and cannot rely on TLS 1.0.

Resolution

  • Upgrade your TLS version to TLS 1.2.
  • Upgrade your CommonCryptoLib / SAPCRYPTOLIB to at least version 8.5.12. 

See Also

 

Keywords

"Cloud for Customer" , KBA , LOD-SF-JAM , SAP Jam , CEC-MKT-CPG , Campaign , LOD-SF-JAM-C4C , Integration with C4C , Problem

Product

SAP Jam Collaboration all versions