Symptom
SAP Jam integration not working
Environment
SAP Jam
Cloud for Customer
SAP Marketing
Reproducing the Issue
Errors:
- In the context of Data Services an unknown internal server error occurred
- Error during processing of OData request
- External user ID does not exist for user ____
- Connectivity error occurred
- HTTP client: POST failed with return code 407 and message SSL handshake with _____:443 failed
Cause
- TLS 1.0 was disabled on all SAP Jam data centers from October 13th to November 11th, 2018 as part of a wider SAP SuccessFactors security hardening project.
- Any systems trying to call SAP Jam now need to support using TLS 1.1 or 1.2, and cannot rely on TLS 1.0.
Resolution
- Upgrade your TLS version to TLS 1.2.
- Upgrade your CommonCryptoLib / SAPCRYPTOLIB to at least version 8.5.12.
See Also
- Integrating SAP Hybris Cloud for Customer with SAP Jam Feeds section of the 'C4C and SAP Jam integration guide': https://help.sap.com/viewer/908c545d8c224add8d17d7bcd3047242/1802/en-US/f93ccfbb506b4332959450ecc82b0f0d.html
- 'Configure Knowledge Base Integration' section of the 'SAP Hybris Cloud for Customer Administrator Guide': https://help.sap.com/viewer/cea15f900ca04c4faa35d3044577fe27/1802/en-US/187ffdb2763d10149917c037594600bb.html
Keywords
"Cloud for Customer" , KBA , LOD-SF-JAM , SAP Jam , CEC-MKT-CPG , Campaign , LOD-SF-JAM-C4C , Integration with C4C , Problem
Product
SAP Jam Collaboration all versions