SAP Knowledge Base Article - Public

2727853 - Scheduled Workflow Does Not Work

Symptom

Scheduled workflows are not getting executed.

Environment

SAP Cloud for Customer

Cause

You have configured these workflow rules to execute when the conditions are satisfied.

That is, the execution is supposed to take place when some action is performed on them. But the rules are configured on field "Created On".

Now consider that the rule is created on 10:00:00, so if the rule is scheduled as 10 second after creation, then it should trigger at 10:00:10. But if the ticket status is changed to 'Assigned' (or condition is fulfilled) at a time after than 10:00:10; when the co nditions are met, then the time of change is in the future compared to the time of execution of the rule.

Hence, it will get cancelled with the reason that the rule was supposed to be executed in the past.

Resolution

To resolve this, first the configuration of the rule should be changed from "Created On" to "Changed On".

Also note that, in case of scheduled rules, the condition evaluation is done twice.

1] At the time of change of object
2] At the time of execution of the workflow rule

So in between these two times, if the data of the ticket changes and the conditions are not met → at the time of execution, then the rule will not execute.

Keywords

KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer add-ins 1811