SAP Knowledge Base Article - Public

2728009 - Error encountered while creating or editing Canvas reports despite correct ORD/ODS setup - Finger Print: e45aed53c7ad81413fc7252969293ea176be431c

Symptom


  • Error occurs when creating or editing Canvas reports despite correct ORD/ODS setup.
  • Finger Print: e45aed53c7ad81413fc7252969293ea176be431c
    .

"Image / Data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental"

Environment

  • SAP SuccessFactors HCM Suite
  • Report Canvas

Reproducing the Issue

  1. Login to the instance
  2. Go to report center
  3. Try to Create / Edit a Canvas report
  4. Bellow Error Occurs

    ERROR.PNG

Cause

The issue is caused by an incorrect JAM URL under the 'Authorized SP Assertion Consumer Services' Settings in Provisioning.

The URL contains double colons instead of a single colon.

incorrectJAMUrl.PNG

Resolution

Correct the incorrect JAM url under Authorized SP Assertion Consumer Service Settings in Provisioning to resolve this issue

Keywords

  • Canvas report error
  • Unable to create canvas report
  • Unable to edit canvas report
  • Incorrect Jam Assertion URL
  • Syntax error in URL
  • Authorized SP Assertion Consumer Service Settings issue
  • Double colons in URL
  • JAM URL error
  • Report center issue
  • Report Designer error
  • ORD/ODS setup issue
  • Canvas report creation failure
  • Canvas report editing failure
  • Error message when creating report
  • Error message when editing report
, KBA , ss_anonymizedkba , LOD-SF-ANA-ORD , Online Report Designer , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , Problem

Product

SAP SuccessFactors HCM Suite all versions