SAP Knowledge Base Article - Public

2729232 - The Extension Field Value Does Not Appear in The OWL

Symptom

You have created an extension field ABC in the Account Business Object and extended this to the Opportunities OWL. (behaviour not specific to this BO) However, the value from the extension field ABC does not pull through to the OWL.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Search for the Opportunity XYZ (XYZ represents the Opportunity ID).
  4. You can see that the extension field in the Opportunity OWL is blank, even though when you open the related Account ABC, there is a value maintained.

Cause

The extension feld value was maintained in the Account ABC after the Opportunity XYZ was created.

Resolution

In order for the value to pull from one BO to another, the value must be maintained before the Opportunity is created. A work around is to edit the Opportunity and Save the changes. The Value will then pull through from the Account.

Keywords

KBA , extension field , business object , owl , value , blank , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions