Symptom
You replicate data from an external system (e.g. ERP, CRM, Sucess Factors etc.) and when the message arrives in Cloud for Customer (C4C), it fails with the following error message:
'Value is no longer than the maximum permitted length X: +123' (X represents the length of the value and 123 the Dialling Country Code)
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
Pre-requisites: you have a working communication scenario between C4C and an external system.
- You send e.g. Business Partners from your external system to C4C.
- Go to the Administrator work center.
- Open Web Service Message Monitoring in the General Settings view.
- Observe the failed message.
Cause
Current issue is that you are sending +123 (CountryDiallingCode) in place of ABC (CountryCode) which is not allowed by C4C.
Resolution
To fix the issue, you should change the middleware mapping and use CountryDiallingCode instead of CountryCode.
Keywords
KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem