SAP Knowledge Base Article - Public

2730127 - Update Item Substitute error LMS

Symptom

When the Update Item Substitute background job runs, the following error is displayed:

Error processing (Batch # 1) ERROR MESSAGE:(org.springframework.jdbc.UncategorizedSQLException: SqlMapClient operation; uncategorized SQLException for SQL []; SQL state [HY000]; error code [133]; SAP DBTech JDBC: [133]: transaction rolled back by detected deadlock: search table error . . . .

Environment

SAP SuccessFactors Learning

Reproducing the Issue

1. Login to LMS
2. Go to System Admin > Background Jobs
3. Make the following Search criteria:
     - Title (contains): substitute
     - Status: Failed
4. Click on Search button
5. View the search result

Cause

The timeout background settings needs to be extended to avoid this issues moving forward.

Resolution

Please raise an case to Product Support so that Support can work with Operations team to set this configuration on the background.

A script to clear the job status may also be needed after the timeout settings is in place to be able to come out of the stuck job.

See Also

LRN-47619, SRSD-38906

Keywords

Update Item Substitute error, transaction rolled back by detected deadlock, Error processing (Batch # 1), ERROR MESSAGE:(org.springframework.jdbc.UncategorizedSQLException: SqlMapClient operation, Deadlock detected , KBA , LOD-SF-LMS-CON , Connectors , Problem

Product

SAP SuccessFactors Learning 1708 ; SAP SuccessFactors Learning 1711 ; SAP SuccessFactors Learning 1802 ; SAP SuccessFactors Learning 1805 ; SAP SuccessFactors Learning 1808 ; SAP SuccessFactors Learning 1811