SAP Knowledge Base Article - Public

2730639 - Unable to change Form Template Settings: Start Date must be before End Date and Due Date - Performance Management

Symptom

When attempting to make a change to Performance Form Template Settings, the system returns the following error at the top of the page after saving:

"Start Date must be before End Date and Due Date"

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Performance & Goals

Reproducing the Issue

  1. Navigate to Admin Center > Form Template Settings;
  2. Choose an affected Performance Form Template;
  3. Change any option and attempt to Update Form Template, see the following error message and the your change is not saved.

error.png

Cause

This error is caused by your template configurations failing the date configuration validations. The Start date of your form must always be before the End and Due date configuration. (Both Default Dates and Feedback Date Ranges)

This error can also be caused by the Ask for Feedback End Date, which is set to a past date.

For example, you configured the default start date, default end date, default due date using fixed date as below:

Default Start Date: 10/01/2019
Default End Date: 09/30/2020
Default Due Date: 09/30/2020
Start date of the "ask for feedback": Relative to "Form Creation Date" (For example, today is 08/18/2023, then the system takes that the form creation date would be 08/18/2023, which obviously falls after the Default End Date and Default Due Date 09/30/2020 and can not pass the validation).

date range configuration.png

Resolution

The Default Start Date validates against the following fields:

  • Default End Date
  • Default Due Date
  • Ask for Feedback Date Range (Even if Ask for Feedback is disabled, the dates must be configured after the Default Start Date)

How to fix: Please make sure that the Ask for Feedback End Date is future dated. This can be achieved in two ways:

1. You can set the start date of the "ask for feedback" as Relative to "Default Start Date" so that it will take the value configured in Default Start Date and surely falls before Default End Date and Default Due Date as shown in below example:

Default Start Date: 10/01/2019
Default End Date: 09/30/2020
Default Due Date: 09/30/2020
Start date of the "ask for feedback": Relative to "Default Start Date" (which will take the value 10/01/2019 and surely it falls before the Default End Date and Default Due Date 09/30/2020 and can pass the validation)

form dates.jpg

2. You can set the start date of the "ask for feedback" as a Fixed date which falls before Default End Date and Default Due Date as shown in below example:

Default Start Date: 10/01/2019
Default End Date: 09/30/2020
Default Due Date: 09/30/2020
Start date of the "ask for feedback": fixed date 10/01/2019 (which obviously falls before the Default End Date and Default Due Date 09/30/2020 and can pass the validation)

resolution fixed date.png

3. Additional note:

Please also notice warning message: "Warning - Mixing Fixed and Relative to Form Creation can result in invalid dates set."

mixed msg.png

It means that if you mix between "fixed and relative", the date configuration may be invalid and form template modification may not be saved. It is recommended to use either "fixed" or "relative".

Keywords

SuccessFactors, SFSF, PM, PMGM, PMv12a, unable to change form template settings, start date must be before end date and due date , KBA , csg_q , LOD-SF-PM-FRM , Forms & Templates , Problem

Product

SAP SuccessFactors Performance & Goals all versions