SAP Knowledge Base Article - Public

2731587 - Replication processes from SF to ERP are not executing - SAP SuccessFactors HXM Suite

Symptom

When running the standard processes that replicates data from SF to ERP, no data is returning to ERP.

When checking your middleware (Boomi or CPI), no execution of the process is found.

If you check ECPAO_RESET_QRY_ADM, you can see that the replication program has status "Sent", but no logs are shown in SRTUTIL.

Other symptom observed is that the payload is being generated in the transaction SXI_MONITOR, but it is connecting to a different system like SAP PI and not to the desired middleware (Boomi or CPI).

This applies to all standard processes that require webservices configuration in SOAMANAGER, like:

  • CPI
    • Replicate Employee Master Data and Org. Assignments from SAP SuccessFactors Employee Central to SAP ERP or SAP S4HANA 
    • Replicate Organizational Objects from SAP SuccessFactors Employee Central to SAP ERP or SAP S4HANA 
  • Boomi
    • Packaged Integration: SuccessFactors Employee Central to ERP Employee Data Replication
    • Packaged Integration: EC to ERP Organizational Management v2.0

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
  • CPI (Cloud Platform Integration)
  • Dell Boomi
  • ERP On-Premise

Reproducing the Issue

  1. Run the replication program (for example ECPAO_EE_ORG_REPL_QUERY)
  2. Open your middleware and you won't see any new execution of the replication process
  3. Go to SRTUTIL transaction in ERP side, and you won't see any execution logs either

Cause

Wrong Consumer Proxy webservice configuration.

Resolution

Please confirm if the Consumer Proxy created for the webservice in SOAMANAGER was set with default logical port, by selecting the entry and clicking on Set Log. Port Default:

soamanager1.jpg

After changing it default logical port, it will be shown as below:

soamanager2.jpg

And the issue will be solved.

See Also

You can also verify if the Consumer Proxy was set as default logical port by checking the program PRG_SRT_SINGLE_CONFIG, according to the instructions below:

  1. Go to transaction SE38 > program PRG_SRT_SINGLE_CONFIG
  2. Search for the Object Name of the Consumer Proxy and open its record

    consumer_proxy.jpg

  3. Go to Configuration tab and click on Display (the glasses icon)
  4. Go to Administration Info tab
  5. If the Consumer Proxy was not set with default logical port, it will be shown as below:

    logical_port.jpg

  6. If it was set with default logical port, it will be:

    logical_port_2.jpg

Replicating Employee Master Data and Organizational Assignments from Employee Central to SAP ERP HCM

Replicating Organizational Objects from Employee Central to SAP ERP HCM

Replicating Employee Master Data from Employee Central to SAP ERP HCM Using Dell Boomi AtomSphere as the Middleware

Replicating Organizational Data from Employee Central to SAP ERP HCM Using Dell Boomi AtomSphere as the Middleware 

Keywords

consumer proxy CO_SFIOMX_ORG_OBJECT_REPL_QRY, webservice, web service configuration, program RH_SFIOM_ORG_OBJ_REPL_QUERY, Packaged Integration: EC to ERP - Generic Object Replication Handler, SXI_MONITOR, Boomi, Replicating Organizational Data from Employee Central to SAP ERP HCM, no logs, srtutil, no log, cpi, hci, process, artifact, iflow, boomi, bib, not replicating, don't replicate, no execution, ECPAO_RESET_QRY_ADM, not executing, not running, soamanager, webservice, ws , KBA , LOD-SF-INT-WS , SAP Web Services for SuccessFactors Integration , LOD-SF-INT , Integrations , LOD-SF-INT-HCI , Standard SF to 3rd Party CPI (HCI) Content , LOD-SF-INT-BOM , Standard SF to 3rd Party Boomi Content , LOD-SF-INT-CPI-ERP , Standard SF to SAP ERP or S/4HANA Integration using CPI , Problem

Product

SAP SuccessFactors HXM Suite all versions