Symptom
"Recovery is configured for the advance, but current user does not have permission to use the PayComponent "error while approving advances workflow
Environment
- SuccessFactors Employee Central
- Advances
Reproducing the Issue
Approve advances workflow --->System will display above error message
Cause
User do not have permission to edit the recovery pay components.
Resolution
When approving advances workflow with recovery enabled, system will check whether the approver has recovery pay component edit permission on the target user.
- If number of installment in the current advance request is 1 ,system will check the one time pay component permission
- If number of installment in the current advance request is more than 1 ,system will check the recurring pay component permission
Provide view and edit permission on the pay component to get rid of above error
Keywords
Recovery is configured for the advance, but current user does not have permission to use the PayComponent Advances Recovery Workflow Pay component , KBA , LOD-SF-EC-ADV , Advances , Problem