Symptom
When you try to manually clear Customer Invoice AAA (AAA represents the Customer Invoice ID) with a Payment XXX (XXX represents the Payment ID), you receive an error message when you click on Clear : "DEF is not a contact for ZZZ".
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Receivables workcenter.
- Go to the Customer Accounts view.
- Search for the Account ZZZ (ZZZ represents the Customer Account) and View.
- Select the items AAA and XXX, then click on Clear Manually.
- Check that the items are selected and click on Clear.
You observe the following error message: "DEF is not a contact for ZZZ".
Cause
This is due to the fact that in Collection Case there is the Contact person DEF maintained for the Invoice which does not exist in Business Partner Master Data > Contact of the Customer account ZZZ.
To see the contact in Collection Cases:
- Go to the Receivables workcenter.
- Go to the Collection Cases view.
- Search ZZZ. You will find the ID in Process with the contact person DEF.
To see the contact in Business Partner Master Data:
- Go to the Receivables workcenter.
- Go to the Customers view.
- Search for ZZZ and click Edit.
- In Tab Contact you will see that there is no contact or another one than DEF.
This could be due to the fact that the Contact DEF in Business Partner Master Data has been removed in meantime.
Resolution
You have to match the Contact Person in Collection Case with the Contact Person in Business Partner Master Data > Contact of the Customer account ZZZ.
Keywords
Collection Cases, Error message, Clear Manually, Contact, is not a contact for, , KBA , SRD-FIN-ACR , Receivables , Problem