Symptom
You released an item for scheduling and then undone the work in progress, however the demand is still visible in Resource Scheduler.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets view.
- Select ticket XXX (XXX represents the ticket ID).
- Go to the Service and Repair facet.
- Add a new item.
- Click on the cogwheel and select Release for Scheduling.
- Go to the Resource Scheduler work center.
- Go to the Resource Scheduler view.
- Demand has been created.
- Go back to ticket XXX.
- Select the item, select the cogwheel and click on Not Work Relevant and after Undo Work Progress.
- Go back to the Resource Scheduler.
- The demand is still available in the list.
Cause
The behaviour as per current design is as follows:
When an item is released for scheduling, the demand gets created. If the demand is assigned to a service technician from Resource Scheduler, then the status of the service ticket item is set to ''Ready''.
When the item is deleted, the demand also gets deleted.
Resolution
If the demand must be removed from the Resource Scheduler, the corresponding ticket item needs to be deleted.
- Go to the Service work center.
- Go to the Tickets view.
- Select ticket XXX.
- Go to the Service and Repair facet.
- Select the item and click on the delete button.
Keywords
Resource Scheduler, Ticket, Release for Scheduling, Undo Work, Not Work Relevant, Item , KBA , LOD-CRM-RES , Resource Scheduling , How To