SAP Knowledge Base Article - Public

2732393 - Blocking Workflows after workflow Completion Or View Completed Workflows

Symptom

  • How do I control the Access to Workflows after they have been completed, Rejected, or Cancelled?
  • Is it possible to control workflow access?
  • error: View Completed Workflows

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • SAP SuccessFactors HCM Cloud
  • Employee Central

Cause

  • Controling workflow access is apart of General Data Protection Regulations
  • It provides the capability to prevent workflow approvers and participants from accessing workflow Read Only pages after it was completed (Approved, Rejected, or Cancelled) for a specific amount of time
  • You do not have the necessary Permission

Resolution

  1. Admin users need to turn on the "Add Permission: View Completed Workflows" Feature in Admin Center > Platform Feature Settings
    1.jpg
  2. After this feature is turned on, this has to be permissioned to users who need to be able to view completed, rejected, or cancelled workflow requests via RBP Permissions
    • The permission is called "View Completed Workflows"
    • rbpee.png
  3. To Control the data access period of completed workflow requests, an Admin user can set the period
    1. Navigate to Permission Role Details > Edit Granting > Data Access Period Settings > Completed
      3.jpg
      • The Period Unit value is represented in Month
        • If Full option was choosen:
          • This means that there is no access period limitation for completed workflows
        • If Restricted option was choosen:
          • 0 means only the user can only view the workflow requests which were completed today
          • 1-999 means the user can view the workflow requests which were completed 1-999 months ago including today
      • If the user has multiple RBP roles and all of the roles are set with different Completed Workflows access period, then s/he inherits the biggest period among all the roles associated with the user
      • view: Enabling Data Blocking for Completed Workflows

Caveates, Expected Behaviors, and Limitations:

  • Approver Behaviors:
    • Set completed workflow access period as 1 month for an example approver
      • Proxy as the Example Approver and attempt to access a workflow request that was approved by the example user more then 1 month prior to today via the "here" link in the approvers notification e-mail
        • The system should block the access and show an error message stating "You do not have the necessary permission."
        • The Proxy user will also not be able to acces the Workflow Details if they search for it via Manage Workflow Requests
      • Proxy as the Example Approver and attempt to access a workflow request that was approved within less then one month prior to today via the "here" link in the approvers notification e-mail
        • The system will allow access to the workflow details page
        • The Proxy user will also be able to access the Workflow Details page if they search for it via Manage Workflow Requests.
  • CC Role Behaviors:
    • Set Completed workflow access period as 1 month for an Example CC Role user in the workflow request
      • Proxy as the Example CC user
        • Navigate to "Pending Requests" page
        • In the my notifications section, workflows that were completed more then a month prior to today will not display in this portlet
        • Only workflows that were completed within the last month will display here is this portlet

FAQ - Additional Information

Q) Where can I get information on this from the Guide?

A) Guide: Implementing and Administering Workflows in Employee Central

Chapter: Granting Permission for Viewing Completed Workflows

See Also

  • 2646054 - Role-Based Permissions take preference over field level visibility
  • 2080722 - How to manage & modify a Workflow that is in progress - Employee Central 
  • 2412557 - Workflow does not respect permissions
  • 2487801 - Job Code is visible in My Workflow request page even though no RBP permission is provided
  • 2080181 - Respect Permission Functionality in Workflow Configurations - EC
  • 2720480 - Does Manage Workflow Requests Respect Permissions?
  • 2616208 - Workflows: How to enable the "View Completed Workflows" permission in Role-Based Permissions (Data Blocking)
  • 2643536 - Error message "You do not have the necessary permission" appears when clicking on the link to redirect to Workflow Approval Page

Keywords

WFL, My Requests Page, Notifications, CC Roles, workflows, SFSF, SFEC, SF EC, EmpCentrl, CC notifications, success factors, ECT-106730,View Completed Workflows, You do not have the necessary Permission, Add Permission: View Completed Workflows" Feature in Admin Center, Platform Feature Settings , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions