Symptom
User is based in Dubai and profile has Dubai Timezone set and the customer's Data Center is based in Australia. The tokens in Email Notifications are shown based on datacenter timezone instead of user timezone.
Environment
Successfactors - Employee Central Workflow
Reproducing the Issue
- Approve the timesheet request for the employee on suppose 21st Nov Dubai Time 6 PM
- You will receive the notification in the email which says the timesheet has been aproved on 22nd Nov since your DC is located in Australia and hence the Australian Time
- Time is picked by with the token RECENT_APPROVAL_DATE
Cause
Due to difference in local time and Data Center time.
Resolution
This is currently expected behaviour. Engineering has categorised this as an enhancement but there is no expected date to support this behaviour.
Keywords
ECT-110097, Email Notification time difference, server time in email token, data, center, Time , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem