Symptom
While attempting to clone old templates you may get the following message on screen.
This will also happen while attempting to saves changes on plans which had been created/used prior to the b1811 release.
**Images are from demo instances**
Environment
- SucessFactors Compensation
- SuccessFactors Variable Pay
Reproducing the Issue
As mentioned above there are two ways this can be replicated.
- Access Compensation Home and clone the previous years template.
- Access the previous years Compensation/Variable Pay template, make changes and while saving this message may populate.
Cause
This happens due to new validations which are now in place for Compensation/Variable Pay.
You are unable to have the same column ID within the one template.
For example, previously you were able to have two separate columns like customField1 and CustomField1 where the second ID would use uppercase.
Resolution
To correct this, you will need to do the following.
- Download the current template xml.
- Rename and change any column ID's which populate within this validation warning message.
- Save the template and import back into your instance as a new plan.
- This should then pass validation and create successfully.
NOTE: As you will be changing custom column ID's you will also need to be mindful of any custom formulas which may include these fields.
When updating the field ID's make sure to check formulas and update them accordingly as well.
Keywords
field not unique, validation warning compensation, field id, clone plan, warning message , KBA , LOD-SF-CMP , Compensation Management , Problem