Symptom
When initiating onboarding from RCM an error is appearing.
ERROR: "Unable to initiate onboarding process. Reason: Conflicting mapping found for fields [WOTCStartDate]. Ensure these fields are mapped only in one entity in admin tools.' [Integration with RCM]"
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors Onboarding 1.0
Cause
Unable to initiate onboarding process. Reason: Conflicting mapping found for fields [WOTCStartDate]. Ensure these fields are mapped only in one entity in Admin Tools.
WOTCStartDate is mapped to different entities of Job Application, Job Requisition, and Job Offer templates.
e.g. WOTCStartDate is mapped to Job Application's Application Date and Job Requisition's Anticipated Start Date, error will occur. See image below for visual reference.
Resolution
For Live Customer(s), Implementation Partner(s), and Consultant(s)
- Navigate to SAP SuccessFactors HCM > Admin Center > Setup Onboarding Integration
- Open Job Application, Job Requisition, and Job Offer templates
- Find WOTCStartDate if mapped to different recruiting fields
- WOTCStartDate should be mapped to a single recruiting field/template (for example, it should only be in Job Requisition templates, not in Job Requisition and Offer templates), kindly remove other mapping and maintain one entity mapped to WOTCStartDate
For SAP SuccessFactors Cloud Product Support
Please use the instruction manual on how to proceed, in the internal note
Keywords
SAP SuccessFactors, Onboarding, OBD, ONB, LOD-SF-OBD, INT, LOD-SF-OBD-INT, Recruiting, RCM, Integration, RCM-ONB, RCM-INT, Unable to initiate onboarding process. Reason: Conflicting mapping found for fields [WOTCStartDate]. Ensure these fields are mapped only in one entity in admin tools. , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , LOD-SF-RCM-INT , Integration Center & Intelligent Services , Problem