Symptom
When executing the report for User Logon Activity, all users are shown as "#" instead of the proper information of the users. Also, some column headers show the label as "Not Assigned".
This can also be seen on other reports that are based on the data sources "User Logon Activity" or "Response Time Statistics", like for example:
- Current Logged on Users
- User Login by IP Address and Performance
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Business Analytics work center.
- Navigate to the Design Reports view.
- Search for the report User Logon Activity.
- Execute the report.
Cause
This issue is caused by a scoping question that is responsible for the tracking of IP address of the users when accessing the system.
Resolution
To solve this issue, scope the question "Enabling this feature will capture individual User IDs and Associated IP addresses of client devices for various usage and response times reporting", by following the below steps:
-
Go to the Business Configuration work center.
- Navigate to the Implementation Projects view.
- Select a project and click Edit Scope.
- Proceed to the step 3 - Scoping.
- Expand the element Administration.
- Select the checkbox for the element Performance and Usage Monitoring.
- Proceed to the step 4 - Questions.
- Expand Administration -> Performance and Usage Monitoring.
- Click the Performance and Usage Monitoring element that is shown up.
- Check the question "Enabling this feature will capture individual User IDs and Associated IP addresses of client devices for various usage and response times reporting".
* Please note that only entries created after the change will be listed with a user name in the report.
Keywords
User Access, Design Report, #, unassigned, scoping, user missing, business analytics, reporting, user report, hashtag, hash tag , KBA , cod_user_logon_ana_q0001 , user not assigned , user shows # , user shows not assigned , cod_user_logon_ana , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-APM , Application & Performance Management , How To