SAP Knowledge Base Article - Public

2734965 - Contracts Creation Date Is Not the Same on the Header and on Changes Tab

Symptom

You have created a Contract and the current date is shown on the Created At field on the Contract Header. However, if you check the Changes tab, you can see that the Change Log with Type equal to Create shows a different date.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Contracts work center.
  2. Open Contract ABC (ABC represents the Contact name).
  3. Check the Created At Date field, it shows the date XX/XX/XXXX (XX/XX/XXXX represents the date of creation).
  4. Now go to the Changes facet and see the Created Date, you will see the date YY/YY/YYYY (YY/YY/YYYY represents the date of creation).

Cause

The Changes facet only list changes at the contract instances.

Resolution

The initial create of a contract instance is not logged.
It may happen that the Contract was initially created on XX/XX/XXXX in the system, but it was first changed by an user on YY/YY/YYYY. In this case, when checking the Changes facet the first change will appear with the "Create" modification type, but they do not indicate that the Contract was actually created at that date.

This is the current and expected system behavior.

Keywords

Contract; Date; Creation; Created At; , KBA , LOD-LE-COP , Contract Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions