SAP Knowledge Base Article - Public

2734989 - The Field Mobile Phone Number is Not Available in Communication for Corporate Accounts

Symptom

Your requirement is to import the Corporate Accounts in system with the Phone, Fax and Mobile Phone numbers using migration. After successful migration of Accounts, you are able to see the Phone and Fax numbers in Accounts, but the Mobile Phone field is not available in the Accounts, even though you provided the Mobile Phone in the migration file.

Environment

SAP Business ByDesign

Reproducing the Issue

Perform migration using the below steps:

  1. Go to Business Configuration work center
  2. Select Implementation Projects view or Overview
  3. Search and Open the activity Migration of Customers
  4. Select Migrate customers using the migration tool
  5. Select You Can Also at the top right corner of the screen and Download Migration Template
  6. Fill the mandatory fields in the General sheet of the migration file.
  7. In the Addresses sheet, fill the mandatory fields, Phone, Fax and Mobile Phone fields
  8. Upload the Migration File
  9. Execute Migration for the respective Migration File with Migration Mode Add new records
  10. Migration is successful 

 

Check if Mobile Phone field contains the Mobile number

  1. Go to Account Management work center
  2. Go to Accounts view
  3. Find the migrated Account ID
  4. Select Edit and choose Addresses
  5. In the Addresses facet, in the section Communication, there is no field Mobile Phone

Cause

Organizations generally do not have a Mobile number. Only persons have a Mobile number. This is the reason Mobile Phone number is not part of the Communication in the Corporate Accounts UI. There are areas in the application where mixed lists like Account object worklist, Migration excel, Reports etc. show Corporate and Private Accounts where there are a maximum of all available fields. Hence, Mobile Phone is shown there.

Resolution

In the migration file, enter a Mobile Phone number in the Addresses sheet only for Private Accounts. For Corporate Accounts, maintain the Mobile number on the Contacts sheet in the migration file and proceed with the migration.

Note:

It is recommended to enter the Mobile Phone number including the country code. Otherwise the system will try to define the country code automatically.

Keywords

Mobile Phone, Phone, Private Account, Corporate Account, Addresses, Communication , KBA , SRD-CRM-ACC , Account Management , Problem

Product

SAP Business ByDesign all versions