Symptom
An Application error is thrown when trying to access "Go to Benefits" for a user.
Environment
SuccessFactors Employee Central: Global Benefits
Reproducing the Issue
-
Search for the affected employee and load his/her People Profile.
- Scroll down to Benefits section.
- Click on "Go to Benefits" to get the error message.
Cause
Incorrect/incomplete data in existing records.
Resolution
The incorrect/incomplete data can be found and corrected in 2 ways.
Solution 1:
-
Navigate to Admin Center > Manage Data > Benefit Enrollment.
- Search for the affected user's enrollment records and don't forget to include inactives during the search.
- Check each of the records and see if all necessary information, for example "Insurance Coverage" for a benefit of type Insurance is maintained or not.
- Correct the data.
Solution 2:
- Navigate to Admin Center > Import and Export Data.
- Export Data for Benefit Enrollment by including inactives and dependencies.
- Download the result as a zip file from Monitor Job.
- Open enrollment related records and see if any mandatory field is missing for any record. For example, open the file "Benefit Enrollment-Insurance Plan Enrollment Details.csv" > Enable filtering for the columns > Filter the "Blanks" in the column "benefitInsurancePlanEnrollmentDetails.coverage.coverageId". The filtered rows are records without Insurance Coverage which is mandatory for every insurance. Correct the data in UI or through import.
See Also
Keywords
Insurance Coverage 97f14bfe72dced877bea3200f626232dadf90e53 getCoverageName BenefitInsurancePlanEnrollmentDetails Go to Benefits , KBA , LOD-SF-EC-GBF , Global Benefits , Problem
Product
SAP SuccessFactors HCM Core all versions