Symptom
When you are entering a Serial ID in a Ticket which does not belong to the Account of the Ticket, system throws an Error message 'Serial ID is invalid'.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to Service Workcenter.
- Navigate to Tickets View.
- Select the New button to create a Ticket.
- Enter the Account XYZ (XYZ is the Account ID).
- In the Serial ID field enter a Serial ID which does not belong to Account XYZ.
You will see an error message 'Serial ID is Invalid'.
Cause
The error message is raised , since the entered Serial ID is not available in the Default Search Query in the Serial ID OVS.
Only two standard queries are provided by SAP. The Default Query is 'Filter by Customer' and an additional Query 'Filter by Customer and Ship-To'. Since bith the queries will only display the Serial ID that are linked to the Customer, the error message will appear.
Resolution
You can follow the below steps to create a new Query which will prevent this error.
-
Open the Ticket layout In HTML5.
- Select Adapt and Edit Master Layout
- Select the New button to create a Ticket.
- Navigate into the OVS of the Serial ID field.
- Select the Advanced filter of the Default Query.
- Clear the Account ID from the Account ID field.
- Save the Query and add the description as 'All'.
- Check the Default Query Check box.
You will be able to add the Serial ID without the error now.
Keywords
Serial ID, Invalid, Ticket , KBA , LOD-CRM-SRP , Service Request Processing , How To