Symptom
This document has been created to assist you in troubleshooting missing / incorrect data issues for standard SuccessFactors migration / replication processes:
- You have a standard SAP integration scenario established using HCI / CPI as a Middleware
- Data contained in the SOURCE system (origin) has not replicated to / is missing from TARGET system (destination) after completion of replication / migration process
Environment
- SuccessFactors BixX
- CPI (Formerly HCI)
- OData API / SFAPI
Cause
Most likely the cause is either related to the data in the SOURCE system OR the API query being performed by the middleware to retrieve this data
Resolution
- Enable OData / SFAPI Payload Logging - 2639894 - [1805 Feature] API Audit Log Availability
- Enable HCI trace-logging for affected artifact / iFlow - 2405576 - Message Processing Log Levels
- Execute the iFlow (for all / subset / specific employees, depending on the issue encountered)
- Secure the corresponding OData / SFAPI audit log record (request / response headers and payloads)
- Secure the Message Processing Logs (MPL) that is generated from this execution (this should be a .zip folder)
- Provide both to cloud support when creating the case
Please perform the above steps before reporting the issue to cloud support.
This should allow Cloud Support to see the following:
- The data as it is being taken from SF
- The data that is delivered to HCI / CPI tenant before mapping / transformation
- The data that is sent from HCI / CPI (after mapping / transformation) that is subsequently delivered to the TARGET system (destination)
Please note - this may not be applicable to troubleshooting custom HCI / CPI developments
Keywords
HCI, CPI, OData, SFAPI, Trace, Log-level, Missing Data, MPL , KBA , LOD-SF-INT , Integrations , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT-HCI , Standard SF to 3rd Party CPI (HCI) Content , How To