SAP Knowledge Base Article - Public

2736821 - Document Reject Notification - Email Notification Comment box is not visible

Symptom

The Email Notification Comment box is not visible when rejecting a Performance Form.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.  

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Open the Performance Form.
  2. Select the "Reject" button.
  3. In the reject page, the "Email Notification Comments" box is not visible.

No email notification comment box.png

Cause

  • The [[DOC_COMMENT]] token has not been added to the Document Reject Notification.
  • The comment section will not appear when the user rejecting the form is in the previous step.

Resolution

The following are different scenarios where you will not have the option to include a comment in an email when rejecting a form:

  • When the [[DOC_COMMENT]] token has been removed from the body of the Document Reject Notification.
  • When the specific notification for that action has been disabled in Admin Tools.
  • When the user rejecting the form is in the previous step.

Keywords

Document Reject Notification, [[DOC_COMMENT]], PM, Peformamnce Management, Form, Comment Box , KBA , LOD-SF-PM-EML , Emails and Notifications , Problem

Product

SAP SuccessFactors Performance & Goals all versions