Symptom
You are creating a new Sales Quote with Product Quantity equal 0 (zero) and noticed that the Product was not added.
The same behaviour is found when a Proposed Product in a Product List has quantity equal 0 (zero).
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Sales Work Center.
- Go to the Sales quote Work Center View.
- Click New Sales Quote.
- Enter an Account and all mandatory fields.
- Add Product manually or Add From List with 0 (zero) quantity.
- Save and Open.
- Go to Products facet.
You can see no line Item or Product added to Sales Quote Product facet.
Cause
Reason for this system behavior is that quick create window does not support default quantity of zero in this view. But system allows adding product with zero quantity under product tab.
Resolution
This is the current expected behavior of SAP Cloud for Customer.
1. If you are a partner: please use cloudsolutionpartner@sap.com or the PartnerFinder.
2. If you are a customer:
Contact your Account Executive;
Check the link https://www.sap.com/services/innovation.html#contact-us.
An alternative option may be to check the SAP Cloud for Customer Influence Site to submit an idea.
Keywords
Sales Quote; Sales Order; Proposed Quantity; Product List; C4C; Automatic Proposal; 0; Zero; product facet; Quick Create View; , KBA , LOD-LE-CQP , Customer Quote Processing , LOD-LE-CQP-CO , Lean Sales Orders , How To