Symptom
Account automatic determination is not working based on contact when you create an activity (Phone Call/Task/Appointment).
Environment
SAP Cloud For Customer
Reproducing the Issue
-
Go to the Activities work center
- Go to the Appointment/Phone Calls/Tasks view
- Click on New button for creating activity
- Fill the field Primary Contact
You see account field is not automatically fills up based on contact
Cause
C4C does not support the step to determine account based on contact for activities.
Resolution
On creating new activity, currently automatic determination of account based on main contact is not supported and this is an expected system behavior.
See Also
This is a new requirement, for which we have an existing feature request already in Influence Platform. You can vote for this here - https://influence.sap.com/sap/ino/#/idea/211771. In every release, We review open feature requests for criticality and feasibility and prioritize in our backlog accordingly
Keywords
Account not populated, Main contact, Task, Appointment, Phone call , KBA , LOD-CRM-ACT , Activities , Product Enhancement