Symptom
The Country Specific Validation Configuration for Payment Information was enabled however, the system does not perform any validation when Payment Information is added from Employee's Profile or Manage Data.
For example, Swizerland with IBAN 21 characters, system accepts more than 21 characters.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors - Employee Central
Reproducing the Issue
1. View Employee's Profile from Switzerland (for example).
2. Navigate to Payment Information portlet.
3. Click on Add/Edit icon.
4. Fill-out the required fields, enter 25 characters for IBAN.
5. Click Save.
Payment Information was saved successfully even the allowable IBAN should only be 21 characters.
Same thing happens when Payment Information is added from Manage Data.
Cause
This is due to the disabled bankCountry from PaymentInformationDetail object.
Resolution
The bankCountry field from PaymentInformationDetail object has to be enabled because this is the reference Country of the Country Specific Validation Configuration.
See Also
Keywords
payment information, country specific validation, iban validation , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem