SAP Knowledge Base Article - Public

2738405 - Scheduled Workflow Rule Does Not Trigger For Some Scheduled Dates

Symptom

Your scheduled workflow rule is not getting triggered if the scheduled date is before the current date.

Environment

SAP Cloud for Customer

Reproducing the Issue

We are considering that you have a scheduled Workflow Rule for the business object Lead, configurated with Time Offset "2" Days, and Relative Time “After" the Event "Start Date".

  1. Go to the Sales work center.
  2. Go to the Leads view.
  3. Click on New.
  4. Define the Start Date at least 3 days before the current date (for example, define the Start Date as 01/XX/YY considering the current date 05/XX/YY)(XX represents the Month and YY represents the Year).
  5. Save and Open your new Lead.
  6. Go to the Workflow Changes facet.
  7. The workflow rule did not get scheduled in the Scheduled Rules even if the workflow rule condition was met. 

Cause

Scheduled Workflow Rules with relative time “After” do not trigger if the scheduled date is before the current date.

For example, if the Lead Start Date is 01/XX/YY the workflow rule will not get triggered because the scheduled date (03/XX/YY – 2 days after) is before the current date (05/XX/YY).

Resolution

This is the expected system behavior.

The workflow rule will only get triggered if the scheduled date is on or after the current date.

Keywords

Scheduled Workflow Rule, After, Workflow Rule , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions