SAP Knowledge Base Article - Public

2739378 - Calendar option is not displaying for dates field in background portlet

Symptom

User is not able to see the calendar option in order the select the date range

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Profile

Reproducing the Issue

  1. Go to people profile page and edit a block which contains date field.

    1111.png

  2. The calendar icon is missing and user is not able to select date.

    2222.png

Cause

The option "Enhanced Keyboard Navigation" is enabled in option-accessiblity

Resolution

By disabling the option "Enhanced Keyboard Navigation" in option-accessiblity, the calendar icon will start displaying again.

If this option is enabled, systems does not render the icon since entering the date form the keyboard is the most efficient way.

This is as per current system design as part of the b1805. Should you wish to enhance the feature, you may log an Enhancement Request by following this KBA: 2090228

Keywords

Calendar icon missing, Calendar Icon, Select Date, Can't select date from calendar, cannot select a date, cannot find calendar, background block, trend block, , KBA , LOD-SF-EP-BGD , Background Elements , LOD-SF-EP-TRD , Trend Elements , Problem

Product

SAP SuccessFactors HCM Suite all versions