Symptom
You have created an extension field for Employees, however you notice that despite having published the adaptation with the extension field added to the Employee screen, the field does not appear for other employees.
Environment
SAP Business ByDesign
Reproducing the Issue
-
Go to the Personnel Administration work center.
- Enter the Employees view.
-
Search and select the employee.
-
Click on the Edit button.
- Click on the user avatar icon at the top right of the screen.
- Click on Key User Settings.
- Click on Start Adaptation Mode.
-
Navigate to either the Employment or Personal Data tab.
- Right click on a screen section, then click on "+Extension Field".
- Create an extension field or add an existing one to the screen.
- On the adaptation panel on the right, click on Publish.
After the steps, the extension field is expected to be available for all employees. However you notice that for certain employees, the field is still not added to the screen by default.
Cause
The employee personal file screen in SAP Business ByDesign is country-specific. If an extension field is added to the screen of a Germany employee, for example, it will not be automatically added to US employees.
Resolution
The extension field must be added to the employee personal file screen for each country where it is needed.
Keywords
Personnel, Administration, Country, Extension Field, Employee , KBA , SRD-HR-PAD , Personnel Administration , Problem