SAP Knowledge Base Article - Public

2740025 - Failed to call SAP Analytics Cloud agent... ensure that SAP Analytics Cloud agent is running... as is reachable from the SAP Cloud Platform Cloud Connector.

Symptom

  •  When trying to "Check configuration" for SAP Analytics Cloud agent in SAP Analytics Cloud (SAC), the following error message appears:

FAILED TO CONNECT2.jpg

Environment

SAP Analytics Cloud 2018

Reproducing the Issue

  1.  Install and configure SAP Cloud Connetor, SAP Analytics Cloud Agent, Tomcat (and SAP Java Connector(JCo))

2.  Log into your SAC tenant.

3.  Go to: System > Administration > Datasource Configuration. Enter the cloud agent configuration details and then click "Check configuration".

    4.  Error Message appears.

Cause

The "Subaccount" and "Region" in the SAP Cloud Connector are incorrect.

Resolution

  1. Log into your SAP Cloud Connector.
  2. Go to: Connector > Add Subaccount; enter the correct subaccount details and click "Save".
  3. Click "Cloud To On-Premise".
  4. Click "Add" ('+' symbol) on the far right of 'Mapping Virtual To Internal System'.
  5. Complete the 'System Mapping' for Virtual and Internal Host.
  6. Re-add the resource: "/C4A_AGENT/, in 'URL Path'. Ensure you select "Path and all sub-paths".
  7. Click Save.
  8. Go back to SAC and click "Check configuration".

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, tomcat , KBA , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem

Product

SAP Analytics Cloud 1.0