SAP Knowledge Base Article - Public

2740929 - Error Message When Trying to Add a Registered Product to a Contract: Serial ID XXX not unique. Please enter a Product.

Symptom

When trying to add a Registered Product to a Contract, the following error message is displayed:

Serial ID XXX not unique. Please enter a Product.

Environment

SAP Cloud for Customer / Service

Reproducing the Issue

  1. Go to the Contracts work center.
  2. Select the Contracts view.
  3. Open Contract ABC (ABC represents the Contract ID).
  4. Select the Covered Objects facet.
  5. Select the Add button.
  6. Maintain Serial ID XXX (XXX represents the Serial ID).
  7. Select the Add button.

The following Error message is displayed:

Serial ID XXX not unique. Please enter a Product.

Cause

The error message is displayed, because there is more that one Registered Product with this Serial ID maintained in the system.

Resolution

This is the expected system behaviour.

In order to add a Registered Product, which does not have a unique Serial iD maintained to the Contract, please follow these steps:

  1. Go to the Contracts work center.
  2. Select the Contracts view.
  3. Open Contract ABC (ABC represents the Contract ID).
  4. Select the Covered Objects facet.
  5. Select the Add button.
  6. Maintain the Product ID of the Registered Product.
  7. Maintain Serial ID XXX (XXX represents the Serial ID).
  8. Select the Add button.

Keywords

Registered Products Contract Serial ID unique Error , KBA , LOD-LE-IBA-IBA , Installed Base , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions