SAP Knowledge Base Article - Public

2741138 - Private Appointment Not Working On Server-Side Integration

Symptom

You are using C4C with Groupware Outlook Integration enabled "Private Appointment" functionality.

However, upon synchronization of private appointment from Outlook to C4C, Appointments are not marked as private.

Environment

SAP Cloud For customer

Reproducing the Issue

  1. Create an appointment in Outlook and mark it as "Private".
  2. Sync the data from Outlook to C4C for newly created appointment.
  3. Check the appointment in C4C.
  4. Please notice that the private flag does not appear and it is openable by other users as well.

Cause

You are using the Server-side integration.

The behavior presented on Differentiate Private Appointments from Regular Appointments only works for Client-side integrations.

Currently Sever-Side integration only strips all the confidential information from the appointment and creates a dummy 'Private Appointment' event in C4C.

Resolution

This is the standard behavior of the system.

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available

Keywords

Private; Appointment; Sync; Outlook; Calendar; Server-Side; Client-Side. , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions