Symptom
You are using restriction rule 11 and 12 to restrict Accounts and Contacts. However, you don't get the correct results.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Administration work centre.
- In the Overview facet, click on Business Users.
- In the Business Role assignment facet, click on assign a role to your user.
- Open the role.
- In the Access restrictions facet, restrict the Accounts and Contacts with read access using the access restriction 11 [Employee, Account (Account team)] or 12 [Employee, Account (Account and Territory Team)].
- Save the changes.
- Log in with the affected user.
- Go to the Customer work center.
- Go to the Accounts or Contacts view.
Expected result: You expect the accounts and contacts to be restricted according to the account team and the territory team (in case of rule 12).
Cause
Restriction Rule 11 and 12 are not meant to be used for Business Partners (which includes Accounts and Contacts). This recommendation is also written in this blog in the SAP Portal. Note: BUPA stands for Business Partners.
Resolution
Instead, you can use Rule 2 if you wish your users to be authorized to see all the contacts/accounts where the logged in user is part of the account team OR part of the territory team.
See Also
Keywords
account, contact, territory team, account team, access rights, access restriction, business role, , KBA , LOD-CRM-ACC , Account , LOD-CRM-PCN , Partner Contact , How To