Symptom
When adding a new Involved Party to a Ticket, the system allows you to save the changes even after the error message Please Use Not More Than 1 Party ABC (ABC represents the name of the Involved Party being used) appearing. This is happening even if you set the Parties as Unique in the Business Configuration.
The same can happen with the error "Please enter a contact for the party with role DEF" DEF represents the party role where no party was entered in the ticket. This party was maintained as mandatory in the business configuration.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Go to Service work center.
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Select the Tickets view.
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Open Ticket XYZ (XYZ represents the Ticket Subject).
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Go to the Involved Parties facet.
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Add a new party, the error message Please Use Not More Than 1 Party ABC appears will appear.
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Hit the save button, your changes will get saved even if you set the Parties as Unique in the Business Configuration.
Cause
For Parties, SAP Cloud for Customer was designed in a way that it will always allow you saving the changes.
In the involved Parties facet you can enter as many parties as you want. The flag "Unique" in Business Configuration Fine Tuning is only used to raise the error message to make the user aware of the configuration. The same applies for the flag "Mandatory".
Resolution
This is the standard behavior of the system, however a Partner Development Infrastructure (PDI) can be created to avoid the saving action.
If you would like a field to be mandatory, and it should not be possible to save a ticket without an entry in that field, you can use the Adaptation mode to make the field mandatory. It will be marked with an asterisk (*) and you cannot save a ticket without that field.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
See Also
Keywords
Party; Tickets; Save; mandatory, unique, save is possible, , KBA , LOD-CRM-SRP , Service Request Processing , How To