Symptom
Internal users can access and review content without any problem in PC and mobile browsers.
The problem starts when external user finishes a course in native mobile browser, then we are facing the next issues:
- Learning history has the record of approval in the learning history portlet, and this is good.
- However, the same course approved still appears in different ways:
- For PC browser, course appears in the self-assigned items, even when the course was finished assigned directly by an admin.
When user clicks on start course, they get a screen asking for an “Order Ticket No.”
If it is not provided, course cannot be run again. - For Mobile browser, it appears in the Learning plan as an actual assignment.
When user tries to start this course, it will show a text: “Remove action is not mobile accessible”. If even with this message we click on Start Course, we will get a final message “the item needs to be purchased through the web app”.
- For PC browser, course appears in the self-assigned items, even when the course was finished assigned directly by an admin.
Issue is only happening in Native Mobile browser, and this error does not come in the SF APP.
Environment
SAP SuccessFactors Learning Management System (LMS)
Reproducing the Issue
Step 1: Login to Learning
Step 2: finishes any scorm 1.2 courses
Step 3: Validate that Learning history record correctly in PC browser
Step 4: In mobile browser validate that course has not dissapeared from learning plan, even when it is recorded in learning history, validate that when you try to run course again it is not allowing to finish and even now it will show a text: “Remove action is not mobile accessible”. If even with this message we click on Start Course, we will get a final message “the item needs to be purchased through the web app”.
Step 5: If after approving the course we open session In PC browser we will find that course appears now in self-assigned items, and if we try to start course from here, we will be required to fill a text for “Order Ticket No.”
Cause
We have found that this behavior comes when mastery score is different than the one defined in the SCORM XML.
Resolution
Fix the mastery score that is different than the one defined in the SCORM XML.
Keywords
native mobile browser, SCORM , KBA , LOD-SF-LMS-CNT , Content , Problem