SAP Knowledge Base Article - Public

2742366 - Access Restriction on objects of Outlook Add-in

Symptom

In the Outlook add-in side panel, you will be able to see certain objects of the Account being grayed out and some are available.

Environment

  • Groupware Outlook add-in
  • SAP Cloud for Customer

Reproducing the Issue

  • In the Outlook add-in side panel, search for any Account.
  • Once the Account information is displayed, you will be able to see its objects. (i.e.: Leads, Activities, Sales Orders, Sales Quotes etc.).
  • Now you will be able to see certain Objects being grayed out as shown in the screenshot.

Outlook Add-in Objects greyed out.jpg

Cause

This is, because the Outlook add-in validates the access restrictions and workcenter view assignment for the logged-in user as per C4C .

Screenshot attached for reference

Access Restrictions.jpg

Resolution

This is a new feature made available for the Outlook Addin. So, if an object is greyed out, it means that the user is not assigned with the necessary access rights to that workcenter view.

Keywords

Side, panel, side-panel, panal objects greyed out, side pane options not showing data , KBA , LOD-CRM-GW-OUT , Outlook , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions