Symptom
While referencing an Email, you will notice options like Opportunity and Lead are sometimes enabled and sometimes greyed out.
Environment
SAP Cloud for Customer.
Reproducing the Issue
-
Click on Add E-mail option for an Email
- Click Add Reference.
- You can observe options like Opportunity and Lead being enabled and sometimes greyed-out.
Cause
-
We first check whether email is associated with any account . If associated then, we will check if the Account in present in local folder "SAP Cloud for Customer Accounts", then all the options will be enabled.
- If not, we loop through 'from email address' and all the 'recipient list (except logged in user)' and try to find out account associated.
- In case any of the user/email-id is associated with more than one account, then lead and opportunity option will be disabled.
- In case two user in recipient list belongs to two different account then lead and opportunity options will be disabled.
- If in email list only one particular user has account associated with , then only lead and opportunity option will be enabled.
Resolution
These are the conditions/ criteria which will be taken into consideration for the options "Lead" and "Opportunity" to be enabled or disabled while adding an Email.
Keywords
Add Reference options disabled, Lead, Opportunity , KBA , LOD-CRM-GW-OUT , Outlook , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions