SAP Knowledge Base Article - Public

2742454 - Application error occurs when an Internal Candidate tries to accept DPCS - Recruiting Management

Symptom

Internal candidate receives a fingerprint error when attempting to accept the Internal DPCS Statement (Data Privacy Consent Statement).

Environment

 SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Navigate to Careers Tab
  2. Click My Candidate Profile
  3. Accept DPCS
  4. Fingerprint error is generated. Fingerprint is different each time the error is reproduced.

Cause

There is already a candidate profile in the system with the same e-mail address as the user.

Resolution

  1. Check User Directory File (Employee Export) for the affected users.
  2. Check Values for e-mail Address.
  3. Check if the value for Username and UsersysID also contain an e-mail address.
  4. Run an Ad-Hoc Report for any candidates in the system containing any of these values.
  5. Update the User Directory File so that the affected user now contains a unique value.

Keywords

RCM, Candidate, Internal, DPCS, Accept, Data Privacy, Consent, Statement, Exception occurred while creating candidate profile, Candidate already exists, Candidate exists with same email, unique constraint violated: Table(RCM_CANDIDATE), Index(UC_UNIQUE_EMAIL_ADDRESS1) , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-CAP , Candidate Profiles , Problem

Product

SAP SuccessFactors Recruiting all versions