Symptom
An email sent as a Recruiting Email Trigger is being sent with faulty tokens. The tokens may either display no information or just resolve as the actual token ID, instead of the token name (e.g.: "[[CANDIDATE_FIRST_NAME]]" instead of the actual candidate/recruiter name)
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- The email is sent when the performed action fits the email trigger point;
- One or more of the email tokens are not resolving as expected.
Cause
There are 2 possible causes for this:
- The used token might not have information where the data should be pulled from. Example: The [[JOB_REQ_LOCATION]] will not resolve any information because, back on the job requisition, the Location field is empty or the location field you are using is an object type which has different token [[LOCATION_OBJ]].
- The (standard) token being used is not supported by that trigger.
Resolution
The solution for each above mentioned would be:
- Provided information to the token data source, so the token may find the information and have it properly displayed in the email.
- Use the Validate Standard Tokens functionality to make sure the used token is accepted with the selected email trigger. For more information on how to do this, please check this article. You can also refer to the "Supported Tokens" section in each trigger to check which tokens they support.
See Also
2486056 - Token Validation in Recruiting Email triggers and Manage Recruiting Email templates - Recruiting Management
Keywords
email, triggers, token, not working, validate, standard, tokens, supported, view. , KBA , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem