SAP Knowledge Base Article - Public

2743462 - Owner Field not Visible in Advanced Search

Symptom

Field is not shown in Advanced Search, unable to add it via the Master Layout as well

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Work Center view for example; Sales Quote.
  2. Select the Query My Sales Quotes.
  3. Click on Advanced Search.
  4. Here you will not be abel to see the field "Owner".
  5. However the same field is visible when you select "All" Query.

Cause

The field is binded to /Root/IsActiveDefaultSetAllQuotes(sap.client.data.IndicatorField) which means the field will be visible only for "All Query". You can check this in Debug Mode in the Client Inspector.

Resolution

This is an expected system behavior.

Keywords

advanced search, All query, , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem

Product

SAP Cloud for Customer add-ins all versions