SAP Knowledge Base Article - Public

2743703 - There is no Warning Message in The Opportunity to Notify The User That The Survey is Mandatory

Symptom

There is no warning/ error message triggered in the Opportunity to Notify the User that the Survey is mandatory.

Environment

SAP Cloud for Customer

Reproducing the Issue

Pre-requiste: You have created the Activity Plan DEF and assigned it to a Routing Rule XYZ. You have added a Survey/Task to the Activity Plan and selected the mandatory checkbox.

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Open the Opportunity ABC (ABC represents the Opportunity ID).
  4. Go to the Surveys tab.
  5. Select the Actions button---> Refresh from Activity Plan.
  6. You can now see the Survey associated with the Activity Plan DEF.
  7. However, there is no warning message/ error message triggered within the Opportunity to notify the user that the Survey is mandatory.

Cause

Currently there is no link between a mandatory Survey within an Activity Plan and the Opportunity where the Activity Plan is executed. Only the Surveys/Tasks will be added into the Opportunity, but no error/warning message will be triggered. This is currently the expected system behaviour.

Resolution

It is a new feature request to trigger a warning/ error message when a mandatory Survey is not completed within an Opportunity. Please please your idea on the Customer Influence Site: https://influence.sap.com/SAPCloudforCustomer

Keywords

KBA , warning , message , activity plan , opportunities , surveys/tasks , mandatory , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins 1811 ; SAP Cloud for Customer add-ins 1902