Symptom
You created a Workflow Rule for the Assignment Business Object.
Within the Workflow Rule you maintained a condition that the Workflow Rule should not be triggered, when a certain Service Technician is maintained in the Assignment.
However, the system ignores the condition and the Workflow Rule gets triggered even for the maintained Service Technician.
Environment
SAP Cloud for Customer / Service
Reproducing the Issue
Pre-Requisite:
The Workflow Rule has a condition maintained for: Service Technician is not equal to value ABC (ABC represents the Service Technician name).
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Go to the Resource Scheduler work center.
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Select the Resource Scheduler view.
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Assign Demand XYZ (XYZ represents the Demand ID) to Service Technician ABC.
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Save the changes.
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Go to the Administrator work center.
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Select the Workflow Rules view.
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Select the Actions button and choose the option Workflow Logs.
In the Logs you can see that the Workflow Rule was triggered for the Assignment created.
Cause
This is the expected system behaviour.
When an assignment is created / updated via Resource Scheduler, the service technician is updated in the Assignment object with the Role - Employee Responsible.
The Employee Responsible party is the service technician in the Assignment.
Resolution
In order to have the Workflow Rule working correctly, please use Employee Responsible instead of Service Technician in the conditions of the Workflow Rule.
Keywords
Workflow Rule Assignment Ticket Service technician condition Resource Scheduler , KBA , LOD-CRM-RES , Resource Scheduling , Problem