SAP Knowledge Base Article - Public

2745887 - Country specific validation configuration not triggering for payment information

Symptom

 Country specific validation  configuration not triggering for payment information

Environment

  • SuccessFactors Employee Central
  • Time Off

Reproducing the Issue

  1. Navigate to admin center---->Manage data--->Country specific validation  configuration--->Create new configuration for  country India
  2. Logic: Length of account number should be 11
  3. Navigate to a user whose country is India --->Add payment information with account number length 10--->System is not throwing any error

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Cause

Bank field is set as not visible in the configuration UI

Resolution

  1. Go to manage data--->Search Personal Information Screen Look up---->Copy the screen id
  2. Admin center---->Search manage configuration UI--->Paste the copied screen ID
  3. Check the visibility of Bank field--->Change visibiity =Yes

Keywords

Country specific validation  configuration payment information , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM suite all versions