Symptom
Country specific validation configuration not triggering for payment information
Environment
- SuccessFactors Employee Central
- Time Off
Reproducing the Issue
- Navigate to admin center---->Manage data--->Country specific validation configuration--->Create new configuration for country India
- Logic: Length of account number should be 11
- Navigate to a user whose country is India --->Add payment information with account number length 10--->System is not throwing any error
Cause
Bank field is set as not visible in the configuration UI
Resolution
- Go to manage data--->Search Personal Information Screen Look up---->Copy the screen id
- Admin center---->Search manage configuration UI--->Paste the copied screen ID
- Check the visibility of Bank field--->Change visibiity =Yes
Keywords
Country specific validation configuration payment information , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HXM Suite all versions