SAP Knowledge Base Article - Public

2747067 - How-To: Reporting an OData API Performance Issue

Symptom

In case a performance degradation or slow performance is encountered for regular API calls that used to complete much faster, please review this KBA on how to report and what information to provide SAP Product Support for analysis and troubleshooting.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite
    • OData API

Reproducing the Issue

  1. Perform the same API call with SF OData API Audit logs enabled.
  2. In OData API Audit Logs, notice increased processing/response time compared to the time taken to process the same query previously.

Cause

There can be several reasons for performance degradation, including overall server health, out-of-memory (OOM) issues, scheduled maintenance, API misuse, metadata inconsistencies, etc.

Resolution


1. Enable OData API Audit logs:

Admin Center > Audit Log Settings

        AuditAvail.PNG

Click "Enable All Payloads" on the OData API tab.

Note: Audit logs will remain active for 4 hours only.

2. Gather the OData Log information:

Navigate to the OData API Audit logs section and look for the corresponding log record with longer processing time and take a note of the following details:

- Session ID or Request ID
- Entity
- Response (ms)

Click the HTTP Message and download all log files (Request Header, Response Header, Request Payload and Response Payload).

Below is a sample photo of were you can obtain this information:

         KBA2_EditFinal.PNG

3. Comparison:

If possible, please provide a timeframe comparison (accompanied by time and date) of High Performance rates vs Low Performance rates.

Example: On January 28th the response from an UPSERT of EmpJob took 14.771ms. Whereas, on January 29th the same UPSERT response took 98.13ms.

As an immediate action, metadata should be refreshed. Often times it resolves such issues, unless it is on server side which would require further analysis and actions from Operations or the respecting API Dev Team.

See Also

  • KBA 3141692 - How to capture API Audit Logs from SAP SuccessFactors
  • KBA 2171588 - OData API Metadata Refresh and Export in SuccessFactors Cloud

Keywords

OData, API, performance, issue, slow, processing, response time, degradation , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , LOD-SF-INT-API , API & Adhoc API Framework , How To

Product

SAP SuccessFactors HCM Suite all versions