SAP Knowledge Base Article - Public

2747209 - Automatic Account Determination is Not Working While Creating Tickets Using OData Services

Symptom

You are trying to create new Tickets using OData services and you noticed that the system is not automatically determining the account for the ticket, based on the contact ID you are providing in the payload.

Environment

  • SAP Cloud for Customer.

Reproducing the Issue

  1. Create a POST request for the target URL https://myXXXXXX.crm.ondemand.com/sap/c4c/odata/v1/c4codataapi/ServiceRequestCollection. (XXXXXX represents the tenant URL)
  2. Provide the mandatory information and the BuyerMainContactPartyID.
  3. Send the request.
  4. Find the created ticket and see no account has been determined based on the contact ID.

Cause

Account populating based on the contact is an UI behavior only. If you check the activity Tickets for Customer Support and go to the Involved Parties section, you can select the Account party role and click on the Maintain Determinations button. There you will see there is no party determination related to the Account based on the contact.

Resolution

When using OData to create new tickets the Account (BuyerPartyID) needs to be provided in the payload along with the contact ID (BuyerMainContactPartyID).

Keywords

odata services, service request collection, servicerequestcollection, c4codataapi, create tickets with odata, automatic account determination , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-INT-API , OData API (C4C Only) , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions