Symptom
On editing the E-mail Address under Communication Channel, it navigates to different screen.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Administrator work center .
- Go to the Service and Social view .
- Under the Communication Channel, click on the hyperlink E-mail Addresses.
- Select XYZ (where XYZ represents the email channel) and click on the Edit Button .
You can see the screen, which open is for different one i.e. for XYZ1 (where XYZ1 represent another email channel).
Cause
Please note that it is not recommended to use the same Channel ID in multiple Email Channels. Each Email Channel should have a unique Channel ID.
If multiple Email Channels share the same ID, then when we try to fetch details for a specific channel (using the Channel ID), the system retrieves several records instead of just one. Since the system only expects a single record, it selects the first one in the list. As a result, any changes or edits you make will only apply to this first record.
This is why, when editing a channel, you always see and update only the first matching record.
Resolution
- Go to the Administrator work center .
- Go to the Service and Social view .
- Under the Communication Channel, click on the hyperlink E-mail Addresses.
- You could click on any of the channels containing the shared ID. It would open a channel in random.
- Change the ID and save.
- On refreshing the list, you can see that one of the channels would be updated with the New ID.
- Continue the process with another e-mail channel containing the same ID, until all channels have unique IDs.
Keywords
Communication Channel ; E-mail address ; Email Address ; ID ; Unable ; Edit ; Same ID ; Error , KBA , e-mail address , LOD-CRM-SC-EML , Email , How To