Symptom
On editing the E-mail Address under Communication Channel, it navigates to different screen.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Administrator work center .
- Go to the Service and Social view .
- Under the Communication Channel, click on the hyperlink E-mail Addresses.
- Select XYZ (where XYZ represents the email channel) and click on the Edit Button .
You can see the screen, which open is for different one i.e. for XYZ1 (where XYZ1 represent another email channel).
Cause
This issue is happening because there are multiple e-mail channels maintained with the same ID. When we make a call to fetch the details of the clicked channel, multiple records are returned (the is made call using the ID).
Since we expect only one record to be returned, we take the first returned record and any changes made are saved on that record.
This is the reason that when any channel is edited, it opens only the first record. We have a current limitation where we do not check for the uniqueness of the channel ID.
Resolution
- Go to the Administrator work center .
- Go to the Service and Social view .
- Under the Communication Channel, click on the hyperlink E-mail Addresses.
- You could click on any of the channels containing the shared ID. It would open a channel in random.
- Change the ID and save.
- On refreshing the list, you can see that one of the channels would be updated with the New ID.
- Continue the process with another e-mail channel containing the same ID, until all channels have unique IDs.
Keywords
Communication Channel ; E-mail address ; Email Address ; ID ; Unable ; Edit ; Same ID ; Error , KBA , e-mail address , LOD-CRM-SC-EML , Email , How To